Stuck on Quicktime for Windows 2.1.2 install

I’ve been trying to install a very old game that seems to use Quicktime. Specifically this one: Het magische boek van oom Ernest : MediaMix Benelux, Overijse, België : Free Download, Borrow, and Streaming : Internet Archive

When I mount the iso, and then run the install.exe, I get some initial setup, and then it opens the quicktime installer:

And that’s it, it’s stuck there.

I ran bottles from the console, and there I see:

22:55:06 (INFO) Launching an executable… 
esync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
002c:err:wineboot:process_run_key Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -r" (2).

And that’s where I’m stuck :frowning:

I also tried installing this game on Virtualbox running Windows XP, and it installs, the quicktime installer also pops up but it lso shows a popup where you can click something like continue to actually install quicktime, I’m not seeing that through wine. Sadly, in Virtualbox the game runs, but then crashes right after the first puzzle/page/level. So I was trying out Wine to see if that would work better, but alas.

Anyway, anybody has an idea what could be wrong or what I can do to find out what is wrong?

Thank you!

Ok, I think I found it, maybe, at least I got a bit further.

What I did, was switch to 32 bit, and Wine vaniglia-6.23. It now seems to install.

Can’t run the game yet though, as it now asks me to insert the disk :sweat_smile: But at least it’s a new error, so progress!

Edit: The error in the console is wine: Read access denied for device L"\\??\\E:\\", FS volume label and serial are not available. if somebody knows it. Googling about it now as well.

Ok, so I got past the “Insert disk” error by copying the data from the disk to a folder, and then in Wine create a fake drive with the correct label set in the configuration.

Sadly, the game then crashed very early in, and kept crashing at the same spot.

I also tried VirtualBox but the game kept crashing there at the same spot as well.

Then, eventually I tried DOSBox-X, installed Windows 98 SE there and the game in that, and that finally worked without any issues.

So sadly no solution using Bottles, but for anybody in a similar situation, try DOSBox-X I guess :stuck_out_tongue: