Star Trek - Birth of the Federation

Ello - I recently got a Steam Deck and wanted to try getting Birth of the Federation running since its a classic.
I went to Get Files to get the all in one package.

I have a Bottle setup with a bundle of differing dependencies downloaded (I don’t know what I’m doing so I downloaded a bunch that look important) and everything installed fine.

Unfortunately my problem is running the game.
Upon running inside a terminal I get the following error:

esync: up and running.
002c:err:wineboot:process_run_key Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -r" (2).
WARNING: radv is not a conformant Vulkan implementation, testing use only.
The instruction at 0x00511398 referenced memory at 0x0000000.
The memory could not be read.

I tried switching the runner to proton, and whilst the error message is slightly different the end result is the same.

Any ideas what I can try next?

Its’ free to download if someone wants to help me solve this puzzle :smiley:

this is the one with all the extra’s? ie babylon 5, borg, etc, i did get this game running on linux mint xfce 20.3 ( ubuntu base ) in a bottle but it was awhile ago, and it was awkward trying to access anything other than the main game. the 2 ways i tried running the game was 1) using explorer to find the exe and 2) there was a small window that would pop-up for about 1.5 seconds and i would click on the shortcut.
success in starting the game was questionable, but if you could start it, it would work fine.

Im not sure how you would get it running on the deck, but i could re-try getting the game up and running on another bottle on linux mint debian edition 5

Birth of the Federation on Bottles

[Star Trek Birth of the Federation on Linux MInt Debian Edition 5 - YouTube]

although i had it running in the config as gl default not vulkan (even though my system runs vulkan)

Oh awesome.
I’ll grab my deck later and try switching from vulkan.

Thanks!

my system is an am3+ 8 core with an 8 gig graphics card

couple of notes:

  1. i had to copy folder using browse c: - into the c: drive
  2. use open explorer ( 3 dots next to browse c: ) to run installer - search for exe under my computer
  3. in programs list press the + symbol to navigate to the .exe file and rename after adding it to program menu - in my case this was -
    /HOME/YOUR USERNAME/.VAR/APP/COM.USEBOTTLES.BOTTLES/DATA/BOTTLES/BOTTLES
  4. all the mod .exe files are named trek.exe hence point 3
    BOTF MODS