Program can be run using Explorer but can't add it to Programs

So I have this 2013 32-bit program, a card game actually, so technically a game :slight_smile: but I used the Applications setup and it’s not a typical game (no 3D, etc). It can be downloaded here (page in Russian) Скачать игру Марьяж Преферанс (Marriage) на русском бесплатно . I have Bottles installed as a Flatpak on Fedora 37.

After creating the bottle, I was able to run the installer by using the “Run executable” option, but the program did not appear in Programs. I am able to start and use it successfully if I go to Legacy WIte Tools → Explorer and there find the executable (under Program Files (x86)) and start it.

However, when I tried to add the executable to Programs by giving the full Linux path (under ~/.var/), the application does not start.

How can I get it to add to Programs and then start in the same way as it starts from Explorer?


I just tried it now and it seems to work for me.
/home/username/.var/app/com.usebottles.bottles/data/bottles/bottles/bottlename/drive_c/Program Files (x86)/Marriage

Does it give any message when you try to launch it with terminal?