No$GBA - How to debug a not working app?

Hi there!

I am on Fedora 36 with GNOME 42 and it is my first time using Bottles.

I have installed the Flatpak version from Flathub.

I have first created a “bottle” with the default game profile and tried to launch the last version of No$GBA (v3.05 from official website problemkaputt.de), a Nintendo DS emulator.

Launching the Bottle, I get “NO$GBA - FATAL - Unexpected error”.

Tried with custom configuration, with the same parameters as in the game profile, but in 32 bits (it is a 32 bits application).

Also tried renaming the .exe without the “$”.

Same error.

How can I debug this, what can I test?

Thanks!

Unexpected errors can be hard to debug, you can try attaching a debugger Logs & Debugger - Bottles

Hi mirkobrombin,
Sorry to have taken this long to answer.
Thanks for your help.
At the moment, I didn’t have much time to debug the problem, so I switch to Windows.
Sorry to not have investigated further, although I appreciate your help.
With time, I use less and less Linux at home, or only on my servers.
I hope Bottles will grow in the future.
Best regards.

Made with ❤️ by Bottles Developers.

proudly hosted by



Privacy Policy