New to Wine stuff can't get some details about an app in bottles quite right

I am trying to get this program used by my church to present the lyrics for music or the scripture passage being read through bottles because our budget is small for a better pc and we got a notebook from a donation to handle this task, but it is too slow with windows and can barely run the program.
I was thinking of using some distro with xfce by default and run the app from bottles, from a vanilla virtual env the app installs and opens, but some menus don’t show their text and the presentation when launched isn’t redering the text at the right place.

I tried to install random dependencies like multiple vcredist versions or iex tricks which actually ended up borking the bottle and I had to start from scratch. I don’t know how the app was built (like language and or frameworks) and running from the command line hasn’t given me some error message that could point me to the missing piece so I thought someone here could help me to look into the right direction on how to troubleshoot this.
The program name is “Glorifica”
The main screen functionally works, I can start and stop projection, but there is a hamburger menu on the left that despite the buttons working isn’t drawing them correctly, the text is missing.

This all in a freshly created bottle btw.

And here when I try to load some slide things are all out of place


This is supposed to show this blue background throughout with the lyrics on top.

I am not sure if it is ok to put the link to where I downloaded the program so I’ll refrain for now, but if it is ok I can point it out to someone willing to try and test their luck with the problem.
Any help or suggestion on where to look into how to figure this out is greatly appreciated.
Have a nice one!

After some trial and error I managed to get some changes, I started adding all the stuff I could, tried different runners and many dependencies injected, yet it only draws the whole background with no text now.


The only error message I’m getting when I try to start a projection is:
00e8:err:listview:LISTVIEW_WindowProc unknown msg 10aa, wp 0, lp 0
Looking it up seems to possibly be related to one ComCtl32.dll, but I’m not sure on how to go about making this available through bottles. I saw that vb6 dependency could have this, but not sure, I think not because I installed this dependency, but no dice still…
Here is my bottle yaml.

Arch: win64
CompatData: ''
Creation_Date: '2024-01-19 15:58:11.200272'
Custom_Path: false
DLL_Overrides: {}
DXVK: dxvk-gplasync-v2.3-1
Environment: Application
Environment_Variables: {}
External_Programs:
    a512d2ed-6591-48f1-b509-049392132b8e:
        arguments: ''
        dxvk: true
        dxvk_nvapi: null
        executable: Glorifica.exe
        folder: /home/marcos/.var/app/com.usebottles.bottles/data/bottles/bottles/Glorifica/drive_c/Program
            Files (x86)/Glorifica
        fsr: null
        icon: com.usebottles.bottles-program
        id: a512d2ed-6591-48f1-b509-049392132b8e
        name: Glorifica
        path: C:\Program Files (x86)\Glorifica\Glorifica.exe
        pulseaudio_latency: null
        removed: null
        script: null
        virtual_desktop: false
        vkd3d: true
Installed_Dependencies:
- arial32
- times32
- courie32
- mono
- gecko
- gdiplus
- mediafoundation
- msftedit
- riched20
- andale32
- arialb32
- comic32
- georgi32
- impact32
- tahoma32
- trebuc32
- verdan32
- webdin32
- allfonts
- dmcompos
- dmstyle
- wsh57
- cnc-ddraw
- iertutil
- amstream
- qasf
- qcap
- qdvd
- qedit
- quartz
- directshow
- dotnet40
- dotnet48
- vbrun6
- d3dx9
Language: sys
LatencyFleX: latencyflex-v0.1.1
NVAPI: dxvk-nvapi-v0.6.4
Name: Glorifica
Parameters:
    custom_dpi: 96
    decorated: false
    discrete_gpu: false
    dxvk: true
    dxvk_nvapi: false
    fixme_logs: false
    fsr: false
    fsr_quality_mode: none
    fsr_sharpening_strength: 2
    fullscreen_capture: false
    gamemode: false
    gamescope: false
    gamescope_borderless: false
    gamescope_fps: 0
    gamescope_fps_no_focus: 0
    gamescope_fullscreen: true
    gamescope_game_height: 0
    gamescope_game_width: 0
    gamescope_scaling: false
    gamescope_window_height: 0
    gamescope_window_width: 0
    latencyflex: true
    mangohud: false
    mouse_warp: true
    obsvkc: false
    pulseaudio_latency: false
    renderer: gl
    sandbox: false
    sync: wine
    take_focus: true
    use_be_runtime: true
    use_eac_runtime: true
    use_runtime: false
    use_steam_runtime: false
    versioning_automatic: false
    versioning_compression: false
    versioning_exclusion_patterns: false
    virtual_desktop: false
    virtual_desktop_res: 1280x720
    vkbasalt: false
    vkd3d: true
    vmtouch: false
    vmtouch_cache_cwd: false
Path: Glorifica
Runner: wine-ge-proton8-27-lol
RunnerPath: ''
Sandbox:
    share_net: false
    share_sound: false
State: 0
Uninstallers: {}
Update_Date: '2024-01-19 17:59:01.478847'
VKD3D: vkd3d-proton-2.11.1
Versioning: false
Versioning_Exclusion_Patterns: []
Windows: win10
WorkingDir: ''
data: {}
run_in_terminal: false
session_arguments: ''