Melodics stopped working after nVidia driver update?

I am running Ubuntu Studio 22.04.1, After much fussing with various wine versions, I got Melodics working quite well in Bottles. I think that it worked for about two months without issue. Yesterday, before I opened Bottles, I did let my system do some updates, which included some nVidia driver updates.

Upon trying to open Melodics, the Play button would turn into a Stop button for only a second or so, then go back, with the program seemingly failing to load entirely.

Can someone give me the basic steps on how to troubleshoot these things? It seemed like the information to which I was lead from the in-program button gave me potentially outdated information.

To be clear, this was working fine, and then just stopped. To add to the confusion, I believe the update was a point release to the 5.15 line of drivers, and I am not knowledgeable enough to know how to roll back to the one that I was on. I have tried switching between some of the different drivers that I have available to me, but none of them seem to resolve the problem.

Thank you in advance for any assistance. I am really itching to get back to my piano practice

I want to follow-up on my post, because it took an extremely long time to be approved, which, thankfully, means that I have solved the problem in the interim. But, when I say “solved”, I just mean that it is presently working on a NEW bottle. The old one still does not work.

While I will be the first to admit that I can get a little carried away with fiddling with settings, runner versions, etc., I think that I had already pretty-well cured myself of doing anything that I couldn’t undo, especially if I didn’t have a reason to do so.

So, what I really want to be able to do in the future is to be able to troubleshoot these sorts of things systematically within Bottles and/or be able to tell when the problem clearly resides outside of bottles.

As I have often heard said, it is one thing to solve a problem, and it is quite another to understand it well enough to be able to replicate it. I was thinking that Bottles removed enough layers of complication that I could reliably figure out how to get where I need to go. Largely, that has proven true, but I don’t feel like I can recommend things like this to other people as long as I run into problems like this. I would also love to have some sort of resource for people who are looking to run Melodics on Linux, like I was, which can allow them to do so in a relatively foolproof manner, because I know it was an important issue for me to solve.

There were some cases where templates got broken in the past. Maybe something like that happened.


In any case. Here are some troubleshooting methods that I use:

1. running flatpak from terminal

This method gives the most info out of all methods. You run Bottles using terminal with this command: flatpak run com.usebottles.bottles. It lists many things and usually when you launch any program it also gives most warnings and errors from the program.

2. run with terminal button

This is actually the easiest method, but I run into many problems with it in the past so I always double check with the first method. You just add the program to programs list and use the “run with terminal” button that is in options next to play button

3. different runners

Not actually a troubleshooting method, but changing runners (even to an older version of the same runner) can also help you give a different error in terminal

4. other Wine programs

Sometimes you don’t know if it’s Bottles fault or the Wine. That’s when you check in other Wine managers to be sure. I actually use Bottles because at the time it was the only one that allowed you to run random .EXEs without searching for a scripted installer online. Nowadays Heroic and Lutris also have this option (in Heroic it’s called sideloading which feels like a wrong term, but that doesn’t matter). Just remember to check the same Wine version on all the Wine managers you test (Soda is based on Wine 7.0 and Caffe is based on the newest which right now is a huge difference, I think both Heroic and Lutris also have runners based on Wine 7.0)

You can make a guide here on forum. Or prepare an installer so it appears in Bottles Installers (refer to readme.MD in this repo if you want to dive deeper into this topic: GitHub - bottlesdevs/programs: Repository for programs installation)