DLL Not found errors when running pre-installed Games

Hello,

I’m trying to run preinstalled games in Bottles, it works in Lutris and also with right click, run with wine but on Bottles I’m getting a DLL not found error. I’m guessing it’s because of the sandbox.

The game is already installed, it was just a zip file. There is no installer.
It’s located on a secondary drive and I did Run Executable and selected the game.exe.

Terminal just shows this:

(09:56:07) INFO Launching an executable… 
gamemodeauto: 
wineserver: using server-side synchronization.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
0024:err:module:import_dll Library UnityPlayer.dll (which is needed by L"Z:\\run\\user\\1000\\doc\\722eefab\\Game.exe") not found
0024:err:module:LdrInitializeThunk Importing dlls for L"Z:\\run\\user\\1000\\doc\\722eefab\\Game.exe" failed, status c0000135
gamemodeauto: 

The dll is there inside the game directory, I did try using the DLL override option to native then built in but did not do anything for this error.
I tried the gaming bottle as well as a custom proton ge bottle but it’s same error with both.
It happens with any preinstalled game I tried so far, just the DLL name changes in the error.

Does anyone know what I can do to fix this? What am I doing wrong?
Is there a way to make bottles see the whole game directory on a second drive and not just the exe file? I’m guessing it only sees the exe and not the whole game folder because of the sandbox.
I checked the preferences and other options but I don’t see an obvious way to make it work.

Next release has a fix for cwd which should fix this

1 Like

Ah great! Will try it out then, thanks.

1 Like

The cwd fix should already be up in version 2022.4.14-trento-2 right?

  • Working directory is now automatically set to the executable parent directory for manual launch

I’m still getting the same errors with this version but I found a workaround for now.
If I manually copy the game folder to the bottle folder like …var/…/bottles/…/drive_c/Games/GameHere and click run executable and browse to that path then it runs well how it should.

However there is one more issue I encountered with adding those to Programs tab manually inside bottle.
I’m trying to add program shortcuts for multiple games in one bottle but if I click Programs > [ + ] and select the exe, the entry gets replaced if the exe is the same name.
Ex:
.var/…/bottles/…/drive_c/Games/GameOne/Game.exe
.var/…/bottles/…/drive_c/Games/GameTwo/Game.exe

RPGMaker Games usually all have “Game.exe” as the executable.
Path/Folder is different but exe is the same name and it’s still replacing the entry in Programs instead of adding a new entry.

I tested it by renaming one game.exe to game2.exe and then it added fine as a new entry.
Is it possible to fix this without renaming the exe files?

the fix is not distributed yet

1 Like

Made with ❤️ by Bottles Developers.

proudly hosted by



Privacy Policy