Can't see .exe files when trying to add a shortcut

Hi!

My problem is, i can no longer see executable files when trying to add a shortcut. I don’t know what i’ve done.

However, if i press ‘run executable’, i can see them when i choose ‘show all files’ option. But when ‘supported executables’ is selected nothing shows. When making shortcuts you can’t change it to ‘all files’, and that is my problem here…Can’t make a shortcut anymore.

This might not be a bottles problem, but i don’t know where to look.

Got my favorite game running on Pop!_OS perfectly only after 10 years of failed attempts, so i’m really happy to have found Bottles.

Any help is appreciated. Don’t want to reinstall.

1 Like

This literally just started happening to me today, I thought I was going crazy. Just made an account to ask this same question.

My main OS is Ubuntu 22.04, and I have Bottles configured with Flatseal to see my home directory. I’ve been successfully adding games in bottles this past week or so.

I tried adding some gaming bottles on my laptop running Linux Mint and I had this same problem where it couldn’t add .exes as shortcuts. I’m now seeing this same issue on my desktop PC when it was working yesterday, and I don’t know why

1 Like

The same problem occurred a few days ago.
Linux Mint 21.2 Cinnamon.

1 Like

I figured i can drag files into that ‘select executable’ window from that folder itself (using GNOME Files or similar) and then i’m able to choose them. Kinda stupid workaround but works if you don’t want to mess with the terminal too much like myself.

I’ll just use my temporary solution until i know what’s causing this to happen. Wasted 3 hours googling yesterday but no dice.

1 Like

Just made an account for this myself too.

I started with bottles (and flatseal) 2 weeks ago and so far it’s been surprisingly easy, no problems at all and have successfully added new bottles and shortcuts before.

I started wondering if i forgot how to add bottles and doing it wrong somehow, but seems i’m not alone with this problem.

Yep, dragging the exe files into the GTK file picker works perfectly. Ive even added desktop entries for the shortcuts like I originally intended. Hope the devs fix whatever is causing us to use this workaround soon. Thanks!

Good news is that nobody here screwed anything up. Bad news is that it probably isn’t even a Bottles bug.

Most probable thing is that some flatpak runtime got bugged. Bottles didn’t have any update in quite some time so it couldn’t have been the problem.

Hi all,

I spent the last few days rebuilding my linux drive due to a kernel upgrade error, so I have a fresh install of Ubuntu 20.04 as a reference. Assuming that is is a flatpak problem and a bug fix is forthcoming (I hope…), how do I upgrade the existing installation? Or, what is the cleanest way to uninstall the existing version and reinstalling? Below is the command trail I used to install via the CLI (taken from the bottles install page):

Configure Linux Distribution (Ubuntu)

  1. sudo apt install flatpak
  2. flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo

Configure/Install Flatpak & Bottles
3) flatpak install flathub com.usebottles.bottles
4) flatpak run com.usebottles.bottles

Install Flatseal Permissions Editor
5) flatpak install flathub com.github.tchx84.Flatseal
6) flatpak run com.github.tchx84.Flatseal

Thanks!

Too add, even if I run the install executable via “Show All Files”, while the install procedure completes normally, the game will not run (no errors… just, nothing)…?!?

Supposedly it should be fixed (to some extent) in 51.10 which has been pushed hour ago, but is still waiting for publishing in flatpak.

There should be no need to uninstall and install it again, but I may be wrong. You should just run flatpak update in the terminal and it should handle the update itself.

Different programs behave differently, need different dependencies and some may not even run using Wine. Research on the internet, in the protondb, winehq and other places to see if anybody was able to run the same program/game.

Awesome! I just bought a whole bunch of games on GoG and want to spend my vacation playing them!

The games in question were working previously (for example: Alien Isolation, which I played all the way through using the WINE runner), so I know they work. I regularly do my due diligence on the web before crying wolf, and all the games that stopped working have the green light every place I looked…? In any case, I thought I had messed something up. Thanks again!

I am sorry then. It’s just my standard set of questions, because many new users forget flatpak permissions and runners/dependencies.

No worries, my friend. Your checklist is a good one, especially since I AM a new user. I just learned early on that most of my stupid questions have a simple solution that a Google search can solve before I bother anyone else…:slight_smile: Thank you again for your help!

I got the same problem. Can’t make shortcuts on Linux Mint 21.2 Victoria.

First time post here. Trying Bottles for the first on MX 23 Linux XFCE Debian 12 based. I’m trying to install a Windows program from the Run Executable button and getting very similar issues. It simply will not see and exe file in the selected directory.

And I’m running 51.10 the version that’s supposed to fix this. Not sure if this is the same bug or a different one.

Issue appears to be from gnome dependency that was updated and broke bottles. You need to downgrade. Here is a quick fix:

sudo flatpak update --commit=779ddf6a44999c6e231aef3b4ffb53d0625ef7af8a0d98a909a9e19e235ed761 com.usebottles.bottles

If you prefer another version, you can also select whatever commit you want from commit version history. Access history list using:

flatpak remote-info --log flathub com.usebottles.bottles