Bottles does not start anymore ImportError: pycurl: libcurl

Hello everyone

I had to reinstall Bottles, because after changing Font size the UI was completely messed up.
I use the flathub version of Bottles, installed via the Software Manager of Linux Mint.

Now after re-installation Bottles does not start at all, you can briefly see that it tries to start and then fails and exits. I also tried flatpak-repair with no success.

After a few tries i gave the Terminal a shot, here is it’s output:

F: No installations directory in /etc/flatpak/installations.d. Skipping
F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/odysseus/.local/share/flatpak
F: Opening user flatpak installation at path /home/odysseus/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: Skipping parental controls check for app/com.usebottles.bottles/x86_64/stable since parental controls are disabled globally
F: Opening user flatpak installation at path /home/odysseus/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: /var/lib/flatpak/runtime/org.gnome.Platform/x86_64/43/6c630f6d2ef139879821de37e5afd5535aa02261140456fff3db9d09b0e8387e/files/lib32 does not exist
F: Cleaning up unused container id 2408461613
F: Cleaning up per-app-ID state for com.usebottles.bottles
F: Allocated instance id 3177941541
F: Add defaults in dir /com/usebottles/bottles/
F: Add locks in dir /com/usebottles/bottles/
F: Allowing wayland access
F: Allowing x11 access
F: Allowing pulseaudio access
F: Pulseaudio user configuration file ‘/home/odysseus/.config/pulse/client.conf’: Error opening file /home/odysseus/.config/pulse/client.conf: No such file or directory
F: Running ‘bwrap --args 44 xdg-dbus-proxy --args=46’
F: Running ‘bwrap --args 44 bottles’
Traceback (most recent call last):
File “/app/bin/bottles”, line 43, in
from bottles.frontend import main
File “/app/share/bottles/bottles/frontend/main.py”, line 37, in
from bottles.frontend.windows.main_window import MainWindow
File “/app/share/bottles/bottles/frontend/windows/main_window.py”, line 30, in
from bottles.frontend.utils.connection import ConnectionUtils
File “/app/share/bottles/bottles/frontend/utils/connection.py”, line 20, in
import pycurl
ImportError: pycurl: libcurl link-time version (7.85.0-DEV) is older than compile-time version (7.86.0-DEV)

So has anyone a idea on how to fix this? Is libcurl the culprint here, or is this just a symptom of another problem with the program itself?

I’m currently using:
Linux Mint 21 x86_64, Mate Desktop
Kernel 5.15.0-56-generic
Nvidia Driver 515.86.01-0ubuntu0.22.04.1
The system is otherwise stable, Browsing, Office Programs, running Games via Steam, using proton, ge-proton, wine etc…, basically everything else runs without a hitch and is behaving as expected.

If you need any more information or a more comprehensive error report let me know :slight_smile:

I also tried to get a trace/error report via gdb, using runtime/org.gnome.Sdk/x86_64/42 and then executing: flatpak run --command=sh --devel com.usebottles.bottles

Which got me to the [:package: com.usebottles.bottles ~] shell but i’m now stuck because i can’t seem to find the right binary to execute. So executing gdb /app/bin/bottles does nothing, i guess thats because “bottles” is a python script and not the actual binary. Thats at least what i can see when i look it up under: /var/lib/flatpak/app/com.usebottles.bottles/x86_64/stable/a82972bbc738c0621d844c97b6f1adf8750a7ee9d7378b5ee828f26eaea9dbde/files/bin

I read several guides including the official flatpak guide on debugging and they all tell me it should be as easy as executing "gdb /app/bin/“enter-your-application-binary-here”, after you enter the shell of course, which is what i did, with the correct SDK.

So if anyone can help also with this process it would be really cool, because then i could deliver a more comprehensive report :slight_smile:

Have a great day