Audio in old games?

So I’ve been gaming on Linux for a while using Steam, even before Proton was around. I always used dual booting for non-Steam games and games that didn’t run on proton. Nowadays, almost everything runs on Proton, so the only reason I ever boot up Windows anymore is the occasional non-Steam game. If I can get those running in Linux I can ditch Windows altogether and Bottles feels like the best way to do that.

So the first I tried is a really old game called Ragnarok Battle Offline. I used to play it back in High School, 2007 or so. I still have it on my Windows hard drive, so I just pointed bottles at the executable, and it more or less just worked. Except audio. So a little diggin online and someone said that the executables need to be in the Bottles directory. So I try that, open “C:” and dump the game folder in Program Files(x86). Still no sound.

I do my best to troubleshoot before begging for help, so I installed another old game, Card Sagas Wars, a fan game built on MUGEN. I fire it up and it has sound! Once. After I closed it, I reopened it and it’s silent too now.

Finally, I booted back into Windows to confirm they both still work on it. They both work, with sound. So now I’m looking for advice on how to troubleshoot this further. Sound always just worked with Proton for Steam games, so I don’t really know where to start. And it’s strange to me that CSW had audio at first then lost it for no apparent reason.

Oh, in case it helps, Arch Linux, Bottles 2022.5.14-trento-3 installed from the AUR, Ryzen 9 5950X, RX 580, 32 Gigs of RAM.

it wouldnt be something stupid like the audio device being swapped about ???

when i run discord flatpak on Linux Mint i sometimes get a " switch audio device " pop-up … i have 7 audio devices in my list, but the one i use is my basic usb gaming headset.

Funny you should mention that, I just had a development. I had my USB C headset on so as not to disturb my wife while she played Pokemon, and launched CSW. The sound came back, though through my speakers. And so I launched it several times with and without the headset plugged in. It almost always works with the headset plugged in, albeit through the speakers not the headset, and almost never without, barring the first time when they weren’t plugged in. Unplugging them mid game does not disable the audio.

Sadly, this did nothing for the first game, Ragnarok Battle Offline. Still, getting closer, maybe a device enumeration issue?

Oh, I’m running KDE. I noticed Bottles is a GTK app, so maybe an inconsistency there?

being honest most of that is above my head …

  • kde vs gtk stuff
  • alsa vs pulse vs pipewire stuff

im a if it works it works kinda person

That is true for Flatpak version since it has sandboxing and can’t access other folders at default. You mentioned using AUR version so I suppose it’s different.

Speaking of, maybe try flatpak version? It is the “flagship” edition so maybe AUR one has a bug and it would be good to report it on github then.

Okay, finally getting back to this. I really didn’t want to install the flatpak version, since I mainly use arch since everything is in the AUR. Also I arrogantly thought that there was no way it was something that simple, so I went on using the AUR version until it stopped working altogether. So I gave up and tried the flatpak version, and lo and behold the sound works. So if anyone stumbles upon this thread looking for why sound doesn’t work, try the flatpak version and copy all of the files into the sandboxed C:\ drive.

1 Like