App for Remarkable tablet doesn't work

I have a “paper” tablet called reMarkable 2 that has a companion application for Windows and Mac (not Linux). The installers can be downloaded from https://downloads.remarkable.com/.

It was working fine with Wine until they stopped the newer versions to support Windows 7 and 32 bits platforms. The latest installer only works with Windows 10 64 bits (version 3.9.2.820), and either with vanilla Wine or Bottle I get this error (got the error running with the option “Launch with Terminal” from Bottle):

wineserver: using server-side synchronization.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
00d8:err:combase:RoGetActivationFactory Failed to find library for L"Windows.UI.ViewManagement.UISettings"

I tried to install many of the “Essentials” dependencies, like DirectX 9 and 10, MS fonts and son on, also tried with different launch options, like using virtual desktop, enabling/disabling DXVX, running from the MS-DOS console… The installation of the application worked without any error, the problem is when I try to execute the app after installed.

2 Likes

For those struggling with the same, what I did is just install an old version with Bottle (that should also works with vanilla Wine) that is one of the latest if not the last version for Win32, version 3.6. The problem is that latest improvements are not there (current version is 3.9), and at some point this version can turn unsupported by Remarkable, making it unable to sync or something else, but in the meantime it does work, and it allows to do 99% of the things you normally would like to do with it: sync your files created from Remarkable, upload PDFs, download as PDF your notes into your PC, and even the sharing of the tablet screen works seamlessly.

The link to download the the old version is not available in the official website, only the latest, luckily for me I had the old installer in my computer from a previous installation, and checking how to download the latest version from the official site, I could figure out what is the link for those that want to download the old version from the official site:

https://downloads.remarkable.com/desktop/production/win/reMarkable-3.6.0.761-win32.exe

More tips:

  • If you have a screen with high definition, even one with 1080p, go to “Legacy Wine Tools” > “Configuration”, then tab “Graphics” and increase in “Screen Resolution” the dpi to 144, 168 or whatever size is best for you, but with older versions of Wine in the past, increasing the value too much caused the app to crash.
  • The app tries to update on each start, cancel the download dialog immediately each time.
  • At the beginning the app didn’t start all the time I tried, but starting it with the option “Launch with Terminal” solved the issue. But then I enabled the option “Change Launch Options…” > “FSR”, and now looks to work without the need to start it from a terminal.

1 Like