Any way to move a bottle to a new location?

I want to move a bottle (“Games”) out of ~/.var/app/com.usebottles.bottles/data/bottles/bottles/Games/ and into ~/Games/. What’s the best way to go about this? Just create a new bottle and copy files from one to the other?

Also, I tried using the AppImage of the CurseForge standalone add-on manager for World of Warcraft, but it wouldn’t recognize the WoW installation in the bottle despite me telling it to look in ~/.var/app/[…] Any Idea why? I assume it has something to do with the Flatpak sandboxing but I’m not sure. I did reach out to CurseForge but I’m assuming they don’t support this install method and might not respond

Update on curseforge: the error seems to have nothing to do with Bottles or Flatpak. I installed WoW to a new Wine prefix at ~/.wine/, the most normal place for a WoW install to be on Linux, and their AppImage fails to recognize it, same as before.

This is an invalid directory or unsupported game

Maybe the Wine prefix needs to be in an unhidden profile? I’ll test that next, I guess. But anyway all this isn’t relevant anymore to the topic.

I would just make a new custom bottle and copy configuration files and saves manually. You need to use Flatseal to give Bottles permission to other folders.
There is an option in the settings called “Working Directory” which probably would work exactly like you want to, but I have never used it so I can’t say for sure. You’d still need to use Flatseal though.

Have you tried windows version inside the same bottle?

1 Like

Thanks for the info.

Overwolf support replied. Turns out the issue with CurseForge is… it doesn’t recognize the parent “World of Warcraft” folder. You need to choose “_retail_” inside that folder, specifically. (Or “_classic_” if needed)

1 Like