After weeks of running WoW and Tradeskillmaster.exe fine, a new error

I run WoW and Tradeskillmaster in the same bottle. I’m on Pop!_OS 22.04 LTS x86_64 running the 5.18.10-76051810-generic kernel. Last night I closed down bottles as usual, and shut down each via the bottles UI stop button before closing bottles itself with command-c from the terminal.

This morning I fired up bottles using an alias for flatpak run com.usebottles.bottles and got the following output:

08:22:52 (INFO) Bottles Started! 
08:22:56 (INFO) Catalog components loaded 
08:22:57 (INFO) Catalog installers loaded 
08:22:57 (INFO) Catalog dependencies loaded 
08:22:57 (INFO) Performing Bottles checks… 
08:22:57 (INFO) Dxvks found:
	 - dxvk-1.10.2
 
08:22:57 (INFO) Vkd3ds found:
	 - vkd3d-proton-2.6-1-5b73139
 
08:22:57 (INFO) Nvapis found:
	 - dxvk-nvapi-v0.5.4
 
08:22:57 (INFO) Latencyflexs found:
	 - latencyflex-v0.1.0
 
08:22:57 (INFO) Runners found:
	 - sys-wine-7.0
	 - soda-7.0-2
 
08:22:59 (INFO) Bottles found:
	 - New WoW
 
08:22:59 (INFO) Library saved 
Traceback (most recent call last):
  File "/app/share/bottles/bottles/window.py", line 154, in set_manager
    self.page_library = LibraryView(self)
  File "/app/share/bottles/bottles/views/library.py", line 43, in __init__
    self.update()
  File "/app/share/bottles/bottles/views/library.py", line 56, in update
    entry = LibraryEntry(self, u, e)
  File "/app/share/bottles/bottles/widgets/library.py", line 78, in __init__
    path = ThumbnailManager.get_path(self.config, entry['thumbnail'])
  File "/app/share/bottles/bottles/backend/managers/thumbnail.py", line 32, in get_path
    return ThumbnailManager.__load_grid(config, uri)
  File "/app/share/bottles/bottles/backend/managers/thumbnail.py", line 42, in __load_grid
    bottle_path = ManagerUtils.get_bottle_path(config)
  File "/app/share/bottles/bottles/backend/utils/manager.py", line 86, in get_bottle_path
    if config.get("Environment") == "Steam":
AttributeError: 'NoneType' object has no attribute 'get'

The UI freezes at this point displaying “Starting up…” and “Fetched 3 of 3 packages, Downloading ~20kb of packages…”

I backed up my bottle to another drive, uninstalled the flatpak and reinstalled, rebooted the machine, but get the same error.

Any idea what next steps might be?

Problem solved.

On a hunch I deleted the contents of ~/.var/app/com.usebottles.bottles/data/bottles/library.yml with vim and bottles successfully booted.

I deleted an old bottle last night and there was still a reference to it in that file.

Made with ❤️ by Bottles Developers.

proudly hosted by



Privacy Policy