Adding a shortcut to run The Sims using bottles on Steam (Deck)

I’ve used bottles to install the original Sims game, because it needed a Windows XP environment and virtual desktop ti be enabled.

The Sims now runs fine when starting it in bottles or when rubbing it from both the old and new CLI. However I can’t seem to get a shortcut working within Steam.

I previously installed Origin and the Sims 2 using bottles as well and those worked fine by adding the cli commands to the launch options, but I can’t seem to use the same for the Sims 1.

So I’m basically looking at getting help to get a shortcut into Steam that would start “Sims” as the program using bottles.

Bottles is installed as a flat pak through the Discover store.

Ok I am one step further, I found out that the programs list is empty when Bottles is launched through a Steam “Non steam game” shortcut, but the programs list works fine when launched from the desktop application launcher.

If I browse C: with the explorer I can also see the installed programs, regardless if Bottles is launched through steam or not. Is there a way to check logging and see what happens? I’m guessing it is some kind of permission issue.

I’m having the same issue, different game. Did you find any solution for this?

No solutions yet. I just tried it via a bash script, but no luck it still can’t load the programs list and accessing the exe directly still seems to restrict the access to just the exe.

For reference I’m using using the following commands:

  • To launch bottles: flatpak run --branch=stable --arch=x86_64 --command=bottles --file-forwarding com.usebottles.bottles
  • To launch the game: flatpak run --branch=stable --arch=x86_64 --command="bottles-cli" --file-forwarding com.usebottles.bottles run -b "The-Sims" -p Sims

Both of these commands work using the Konsole, but not when set as launch options within Steam.
I’ve also tried adding --filesystem=host for file system permission but no luck.
I’ve also used flatseal to add both /home/deck and the bottle folder, but still no luck

To add even more info. Here are the log from running bottles from Steam (with Steam launching from Konsole), and the exact same command running bottles from Konsole (terminal).

I don’t see any direct difference.

(Edit: I feel stupid, I did not open the actual bottle. So I now open the actual bottle)

Its definitely a bit strange. Hoping this issue can be fixed as bottles has been more successful (and, for me, easier to use) overall than Lutris. Running a bottle from Steam without friction would be great.

This but should have been fixed with 2022.5.14-3

I have the same problem. Tried to install NFS Underground 2 - runs good (with the virtual desktop config) but when i open it through steam the game disappears - so i have to browse through the entire system to te exe file then click it and run it…

You can try creating a custom entry (bypassing steam) by adding a program, you can see how to do it on our wiki